mynee
09.02.2023 10:35

Дано уравнение «3*5=?». Напишите программу, которая будет проверять, если пользователь ввел правильный ответ,то вывести на экран «Верно», иначе «Не верно». Нарисуйте блок-схему. ПАЙТОН

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Фариза04
18.05.2022 05:14

В город М напрямую можно попасть только из города Н (в который напрямую можно попасть только из города Ж), и из города Ж. Значит, для любого пути в Ж из А есть два варианта, как проехать в М.

В город Ж можно попасть напрямую из городов В, Г, и Д. В город В из города А можно попасть тремя путями: АБВ, АГВ и АБГВ, в город Г - двумя: АГ и АБГ, в город Е - тремя: АГЕ, АДЕ и АБГЕ.

Итого: Из города А в город Ж есть 3+2+3=8 путей, из Ж в М - 2 пути. Для каждого пути из А в Ж есть оба варианта пути из Ж в М, поэтому умножаем: 8×2=16 путей.

ответ: 16 путей

Буду очень благодарен, если Вы отметите мой ответ как лучший!

0,0(0 оценок)
Ответ:
esenjel
02.08.2021 19:57

#include <iostream>

using namespace std;

// функция с алгоритмом двоичного поиска  

int Search_Binary (int arr[], int left, int right, int key)

{

int midd = 0;

while (1)

{

 midd = (left + right) / 2;

 

 if (key < arr[midd])       // если искомое меньше значения в ячейке

  right = midd - 1;      // смещаем правую границу поиска

 else if (key > arr[midd])  // если искомое больше значения в ячейке

  left = midd + 1;    // смещаем левую границу поиска

 else                       // иначе (значения равны)

  return midd;           // функция возвращает индекс ячейки

 if (left > right)          // если границы сомкнулись  

  return -1;

}

}

int main()

{

setlocale (LC_ALL, "rus");

 

const int SIZE = 12;

int array[SIZE] = {};

int key = 0;

int index = 0; // индекс ячейки с искомым значением

for (int i = 0; i < SIZE; i++) // заполняем и показываем массив

{

 array[i] = i + 1;

 cout << array[i] << " | ";

}

 

cout << "\n\nВведите любое число: ";

cin >> key;

 

index = Search_Binary (array, 0, SIZE, key);

if (index >= 0)  

 cout << "Указанное число находится в ячейке с индексом: " << index << "\n\n";

else

 cout << "В массиве нет такого числа!\n\n";

 

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота