эмсикалаш
20.08.2022 16:22

ПО ИНФОРМАТИКЕ не понимаю Зайти в среду программирования PascalABC.

Написать программу (представленную на

слайде № 9). (первая картинка снизу)

2. Выполнить, протестировать и отладить

программу.

3. Протестировать скомпилированную

программу на числах 25 и 30.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
milamilmi
04.10.2021 02:09

Как называется программа?

ответ: cup_of_tea

Запишите какой тип переменных используется в программе.

ответ: real

Запишите названия используемых переменных.

ответ: a, b, c, y , x

В какой строке программа получает данные от пользователя? Напишите номер строки

ответ: 5) readln(a,b,c);

Что будет выведено на экран, если пользователь введет значения: 6, 9, 3

ответ: 1.8

Объяснение:

Вы ввели неверный код, это может быть:

program cup_of_tea;

var a, b, c, y , x: real;

begin

, введите три числа');

   readln(a,b,c);

   y:=a;

   if b>y then y:=b;

   if c>y then y:=c;

   if (a>b) or (a>c) then x:=a;

   if (b>a) or (b>c) then x:=b;

   if (c>a) or (c>b) then x:=c;

   writeln (y+x);

end.

0,0(0 оценок)
Ответ:
alex27045
18.11.2021 23:33

/*Твой код написан на С++, поэтому я так понимаю, что ответ нужен также на нём.*/

#define _CRT_SECURE_NO_WARNINGS

#include <iostream>

#include <string>

#define SIZE 256

int main() {

   const char* DELIMITERS = "_.,;:\n\t!?";        

   char S[SIZE] = "Hello, my2. friend_ia2m?hh2";    

   char* ptr = 0;  

   ptr = strtok(S, DELIMITERS);

   while (ptr) {                

       for (int i = 0; i < strlen(ptr); i++) {

           if (isdigit(ptr[i]))

               std::cout << ptr << "\n";

       }

       ptr = strtok(0, DELIMITERS);    

   }

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота