zizigi
27.04.2023 01:58

1) дан одномерный массив найдите сумму всех элементов массива , выведи на экран сам массив и сумму его элементов

2) дан одномерный массив найдите минимальный и максимальный элемент и выведите на экран​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kate24512
12.10.2020 11:03

1)Program massiv;

Var mas:array[1..20] of integer;

a,b,i,sum:integer;

Begin

sum:=0;

For i:=1 To 20 Do

begin

mas[i]:= random(100); {Заполняем массив случайными числами в промежетке от 0 до 99 (можешь изменить промежуток}

write(mas[i],' ');

end;

Writeln('Введите a,b');

Readln(a,b);

For i:=1 To 20 Do

begin if (mas[i]>a) and (mas[i]<b) Then

sum:=sum+mas[i];

end;

Writeln(sum);

end.   

0,0(0 оценок)
Ответ:
Arinka2184
12.10.2020 11:03

1) дан одномерный массив найдите сумму всех элементов массива , выведи на экран сам массив и сумму его элементов

1)Program massiv;

Var mas:array[1..20] of integer;

a,b,i,sum:integer;

Begin

sum:=0;

For i:=1 To 20 Do

begin

mas[i]:= random(100);

в промежетке от 0 до 99 }

write(mas[i],' ');

end;

Writeln('Введите a,b');

Readln(a,b);

For i:=1 To 20 Do

begin if (mas[i]>a) and (mas[i]<b) Then

sum:=sum+mas[i];

nd;

Writeln(sum);

end.   

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота