dontsovaelizav
19.11.2022 21:31

Переведите код из с++ на язык python
#include
#include
#include
#include
using namespace std;
int m,n,i,j,k;
int a[101][101],b[101][101];
int main()
{ freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
cin >> n >> m;
for (i = 1; i <= n; i++)
{
for (j = 1; j <= m; j++)
{
cin >> a[i][j];
b[0][j]=100001;
b[j][0]=100001;
}
}
b[0][1]=0;
b[1][0]=0;
for (i = 1; i <= n; i++)
{
for (j = 1; j <= m; j++)
{
b[i][j]=min(b[i-1][j],b[i][j-1])+a[i][j];
}

}
cout << b[n][m];
return 0; }

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
maulee502owkszf
01.06.2021 21:49
{Напишите программу, которая находит минимальное и максимальное
среди чётных положительных чисел, записанных в файле,
и выводит результат в другой файл.}
var f:text;
  min, max,a :integer;
  find:boolean;{есть/нет числа удовлетворяющие условию}
begin
 assign(f,'dan.txt'); reset(f);
 min:=0; max:=0;
 find:=false;
 while not eof(f) do
 begin
  read(f,a);
  if not find and (a>0) and (a mod 2=0) then
  begin
   min:=a; find:=true;
  end
  else
  if find and (a>0) and (a mod 2=0) and (min>a) then
   min:=a;

  if (a>0) and (a mod 2=0) and (max<a) then
   max:=a;
 end;
 close(f);
 assign(f,'res.txt');
 rewrite(f);
 if max=0 then writeln(f,'чётных положительных чисел нет')
  else
   writeln(f,'min среди чётных положительных чисел =',min, chr(13),
      'max среди чётных положительных чисел нет',max);
  close(f);
end.
0,0(0 оценок)
Ответ:
tuzor
12.03.2020 05:53
{В двухмерном массиве найдите количество и произведение не кратных 4
трехзначным элементов k-го столбца}
var
 C:array [1..100,1..100] of integer;
 p: longint;
 kol, k:byte; {кол-во отрицательных эл-тов}
 N,M,i,j:byte;
begin
  writeln('введите размерность массива (кол-во строк, столбцов)');
  readln(N,M);
  writeln('введите элементы двумерного массива');
  for i:=1 to N do
  for j:=1 to M do
   read(C[i,j]);
  writeln('введите номер столбца');
  readln(k);
  kol:=0; P:=1;
   for i:=1 to N do
   if  (C[i,k] mod 4<>0) and (C[i,k]>=100) and (C[i,k]<1000) then  {не кратно 4, трехзначное}
   begin
     P:=P*C[i,k];
     kol:=kol+1
   end;
   writeln('kol=', kol:7);
   writeln('произведение=', P:5)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота