FantomLord24
29.10.2021 19:49

2. Напишите программу, которая выводит в порядке убывания все составные (не трёхзначные числа.
3.Пользователь программы вводит два целых положительных числа «а» и «b», задающих
диапазон целых чисел [а;b].Найдите и выведите максимальное количество делителей у
чисел из заданного диапазона.
4. Напишите программу, выводящую значения функции y = 2х – 5 на
промежутке (-29;35] с шагом 0,4.
5.Напишите программу, выводящую все делители произвольного целого
положительного числа В pascal

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Дашуля110506
10.12.2022 23:34

=С$5-$B3, проверяла в екселе

Объясния: если в екселе использовать значок $ то ми фиксируем или столбец или строку.

В нашем случае С$5 ми зафиксировали 5, а в $B3 ми зафиксировали В.

Наша формула стояла в клетке D5, а когда ми скопировали её в Е6. То в первой части формулы тоесть С$5 в формуле столбец с C передвинулся на D потому что мы его не фиксировали, а 5 так и осталось потому что оно зафиксированное. Тогда получилось D$5. А другая часть формулы то есть $В3 наоборот столбец В так и остался, а с 3 стала 4. И у нас получилось $В4. Все передвинулись только на одину букву и цифру потому что ми переместили формулу с D5 в E6 а кто на один столбец вправо и на одну цифру вниз.

0,0(0 оценок)
Ответ:
Ksenichka777
10.07.2020 19:07
1. "Школьное" решение

// PascalABC.Net 3.0, сборка 1066
var
  s,s1:string;
  i:integer;
  a:char;
begin
  Write('Введите натуральное число любой длины :'); Readln(s);
  Write('Введите цифру, которую надо удалить: '); Readln(a);
  s1:='';
  for i:=1 to Length(s) do
    if s[i]<>a then s1:=s1+s[i];
  Writeln('Результат: ',s1)
end.

Тестовый прогон:
Введите натуральное число любой длины :3141592653589793
Введите цифру, которую надо удалить: 5
Результат: 3141926389793

2. Современное решение (так в школе почему-то не учат)

// PascalABC.Net 3.0, сборка 1066
begin
  var s:=ReadString('Введите натуральное число любой длины :');
  var a:=ReadChar('Введите цифру, которую надо удалить: ');
  Write('Результат: ',s.Replace(a,''));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота