lpp210103
21.04.2022 00:36

Нужно составить программу в Pascal ABC, которая будет разворачивать числа, например, 234=432​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yaxyeu
27.08.2020 23:18

Var

n, m:integer;

a:byte;

Begin

readln(n);

m:=0;

while n>0 do begin

a:= n mod 10;

n:= n div 10

m:= m*10+a

end;

writeln(m) ;

End.

0,0(0 оценок)
Ответ:
ЭвелинаEvelina
27.08.2020 23:18

Для любого количества символом/цифр

begin

 var stroka := ReadString('Введите число/слово');

 for var i := Length(stroka) downto 1 do

   stroka += stroka[i];

 Delete(stroka, 1, length(stroka) div 2);

 Println('Реверс: ', stroka);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота