Nkpr
19.01.2022 10:46

Как стереть шарик с координатами Х, У в Кумире?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
smirnovigor
12.05.2020 00:12
Решение на VB.NET:
        Const SIZE As Integer = 4
        Dim a, sum As Integer
        a = Console.ReadLine()
        sum = a
        Dim n(SIZE) As Integer
        For i = 1 To SIZE
            n(i) = a Mod 10
            a \= 10
        Next
        For i = 1 To SIZE
            For j = i + 1 To SIZE
                If n(i) > n(j) Then
                    Dim t As Integer
                    t = n(i)
                    n(i) = n(j)
                    n(j) = t
                ElseIf n(i) = n(j) Then
                    Console.WriteLine("Ошибка")
                    Exit Sub
                End If
            Next
        Next
        For i = 1 To SIZE
            sum += (n(i) + n(SIZE - i + 1)) * 10 ^ (i - 1)
        Next
        Console.WriteLine(sum)
        Console.ReadKey()
Сданной . условие - составьте программу которая учитывает все варианты, все цифры в четырехзначном ч
0,0(0 оценок)
Ответ:
Agetnor
22.11.2022 17:50
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество элементов массива:');
  var x:=ReadReal('Введите значение Х для заполнения массива:');
  var a:=ArrFill(n,x); a.Println
end.

Пример
Количество элементов массива: 13
Введите значение Х для заполнения массива: 2.5
2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5

begin
  var n:=ReadInteger('Количество элементов массива:');
  var x:=ReadInteger('Введите начальное значение Х для заполнения массива:');
  var a:=ArrGen(n,i->i+x); a.Println
end.

Пример
Количество элементов массива: 15
Введите начальное значение Х для заполнения массива: 8
8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота