Tasuhka
20.07.2021 04:18

Нужна блок схема :Составить программу, которая находит все пары положительных целых чисел х, у , удовлетворяющих уравнению А*х+В*у=С, где А, В, С - натуральные числа, причем С>max(A,B).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
efimovap17
13.09.2022 19:59

class Person(object):

   def __init__(self, name = 'Bob', age = 25): #Значения по умолчанию заданы в конструкторе

       self._name = name  

       self._age = age  

   @property

   def name(self): #Свойство, возвращающее значение obj._name  

       return self._name

   

   @property

   def age(self):  #Свойство, возвращающее значение obj._age

       return self._age

   

   def say_hi(self): #Рандомный метод

       print(f'Hi, im {self._name}, im {self._age} yo')

   

   def set_age(self, value): #Метод для изменения значения свойства obj._age

       if value in range(1, 101):

           self._age = value

       else: raise RuntimeError('Bad Argument', f'Cant set age {value}, age must be in range [1, 100]')

Объяснение:

Второй класс попробуй реализовать сам

0,0(0 оценок)
Ответ:
hashedhashed1
30.05.2020 06:37
#include <iostream>
#include <string>
#include <cstdlib>
#include <algorithm>
using namespace std;
typedef unsigned short int USI;

int* fillArray(string name, int s);
int maxArray(int[], int s);
bool isPrime(int);
void deleteAllEqualTo(int[], int s, int value);
float averageOfPositive(int[], int s);
void printArray(int[], int s);

bool sortByDescAbs(int i, int j) {
return abs(i) > abs(j);
}

int main() {
setlocale(LC_ALL, "Russian");
USI n;
cout << "n = ";
cin >> n;
int* z = fillArray("z", n);
int max = maxArray(z, n);
if ( isPrime(max) ) {
deleteAllEqualTo(z, n, max);
}
float avg = averageOfPositive(z, n);
cout << "среднее: " << avg << '\n';
sort(z, z + n, sortByDescAbs);
cout << "z[" << n << "]: ";
printArray(z, n);
return 0;
}

int* fillArray(string name, int s) {
int array[s];
for (int i = 0; i < s; i++) {
cout << name << "[" << i << "] = ";
cin >> array[i];
}
return array;
}

int maxArray(int a[], int s) {
int max = a[0];
for (int i = 1; i < s; i++) {
if (a[i] > max) max = a[i];
}
return max;
}

bool isPrime(int n) {
if (n < 2) return false;
if (n == 2) return true;
if (n % 2 == 0) return false;
for (int i = 3; (i*i) <= n; i += 2) {
if (n % i == 0 ) return false;
}
return true;
}

void deleteAllEqualTo(int a[], int s, int value) {
for (int i = 0; i < s; i++) {
if (a[i] == value) a[i] = 0;
}
}

float averageOfPositive(int a[], int s) {
unsigned int sum = 0,
count = 0;
for (int i = 0; i < s; i++) {
if (a[i] > 0) {
sum += a[i];
count++;
}
}
return (sum / count);
}

void printArray(int a[], int s) {
for (int i = 0; i < s; i++) {
cout << a[i] << ' ';
}
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота