ооо322
07.05.2023 04:14

Напишите программу получения следующей формы: (Решение)



* A * B * A+B * A-B * A/B * A*B *



6 2 8 4 3 12

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
123456qwe1234567
09.07.2020 22:35
#include "stdafx.h"
#include <stdio.h>
#include <windows.h>

int main()  
  {
    SetConsoleCP(1251);      
    SetConsoleOutputCP(1251);  
 
int const n=3;
int mas[n][n];
int sum1, sum2;
bool magik;

for (int i=0; i<n; i++)
    for (int j=0; j<n; j++)
         {
           printf("mas[%d][%d] = ", i+1, j+1);
           scanf("%d",&mas[ i ][ j ]);
         }

printf("\nВведенная матрица:\n");
     for (int i=0; i<n; i++)
        {
             for (int j=0; j<n; j++)
                       {
                          printf("%d  ",mas[ i ][ j ]);
                       }
             printf("\n");
         }

sum1=0;
sum2=0;

for (int i = 0; i<n; i++)
     {
            sum1 += mas[ i ][ i ];
            sum2 += mas[ i ][ n-1-i ];
      }

printf("Сумма главной диагонали = %d\n", sum1);
printf("Сумма побочной диагонали = %d\n", sum2);

magik = true;
for (int i=0; i<n; i++)
    {
        if (sum1==sum2)
             {
                 sum2=0;
                 for (int j=0; j<n; j++)
                    {
                        sum2 += mas[ i ][ j ];
                     }
              } else  { magik=false; break; }
     }

if (magik==true)
     {
           for (int i=0; i<n; i++)    
               {
                   if (sum1==sum2)
                        {
                           sum2=0;
                           for (int j=0; j<n; j++)
                               {
                                   sum2 += mas[ j ][ i ];
                               }
                         }
                        else  { magik=false; break; }
                 }
       }

if (magik==true)
    printf("\nМатрица является магическим квадратом\n");  
else
    printf("\nМатрица не является магическим квадратом\n");

system("pause");
return 0;
}
0,0(0 оценок)
Ответ:
ира1025
27.07.2021 00:43

1. Актуальная: Экологическая обстановка в мире с каждым днём ухудшается.

2. Неактуальная: Чтобы добыть огонь, нужно стукать камушек о камушек.

3. Достоверная: Силы, с которыми тела действуют друг на друга, равны по модулю и противоположны по направлению (информация из учебника).

4. Недостоверная: Люська из пятого подъезда ведёт разгульный образ жизни (слова соседки-сплетницы).

5. Объективная: Часы показывают 17 часов 50 минут.

6. Необъективная: Сейчас вечер.

7. Полная: Красный свет - стой, жёлтый - приготовься, зелёный - иди.

8. Неполная: Красный свет - стой, зелёный - иди (для трёхцветного светофора)

9. Полезная: Не сутулься, а то рано состаришься!

10. Бесполезная: В соседней деревне нет ни одного Олега.

11. Понятная: Два плюс два равно четыре.

12. Непонятная: жык лопр дыв мыг

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота