Orlolo
09.03.2021 00:09

Цикл с параметром. Поиск числа.
Напишите программу, которая в последовательности натуральных чисел
определяет минимальное число, оканчивающееся на 4. В программу сначала
Вводится количество чисел, а затем сами числа.
Входные Выходные | Входные Выходные | Входные Выходные
данные данные данные данные | данные данные
14
24
14
20
34​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vladkoles36
11.10.2020 18:17

program min_na_4;

var

i,n,x,m:integer;

begin

read(n);

for i:=1 to n do

begin

read(x);

if x mod 10 = 4

then

if m=0 then

m:=x

else

if m>x then

m:=x

end;

write(m)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота