написать программу на языке Pascal, соблюдая всеусловия

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ilyafedoseev
11.10.2020 15:37

procedure Получить_и_вывести(n: integer; a: array of integer);

begin

 Write('Вектор №', n, ': ');

 a.Println;

 Println('Количество инверсий:',

     a.Pairwise.Where(p -> p[0] > p[1]).Count)

end;

begin

 var (m, n) := ReadInteger2('Задайте M и N:');

 var G := MatrRandom(m, n, -99, 99);

 G.Println;

 Writeln;

 var A := G.Row(0);

 Получить_и_вывести(1, A);

 var B := G.Row(1);

 Получить_и_вывести(2, B);

 var C := G.Row(2);

 Получить_и_вывести(3, C);

 var D := G.Row(3);

 Получить_и_вывести(4, D)

end.


написать программу на языке Pascal, соблюдая всеусловия
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота