марина7811
19.03.2022 00:21

Напишите программу, которая вводит натуральное число N и находит сумму всех натуральных чисел от 1 до N .

Входные данные
Входная строка содержит единственное целое число N .

Выходные данные
Программа должна вывести сумму натуральных чисел от 1 до введённого числа N .

Примеры
входные данные
100
выходные данные
5050

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
rahim55
05.08.2020 16:22

Вот,программа на языке Pascal

program summa;

var n,a,c: integer;

begin

readln(n);

a:=0;

c:=1;

repeat

a:=a+c;

inc(c);

until c>n;

writeln(a);

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота