valeravolc1990o
02.03.2022 17:04

Написать программу Бинарного поиска от 0 до 20 на Сишарпе (можно и с фор ич)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
55555Даша11111111111
30.07.2022 00:43
Для преобразования текстовых данных в числовые каждый язык программирования имеет свои средства.
1. Ввод (чтение) данных. В любом языке оператор ввода читает текст в виде потока (последовательности) символов, получая их внутренние коды в соответствии с установленной таблицей кодировки. Далее, если эти данные должны быть присвоены, как указано в операторе ввода, числовым переменным, производится выделение последовательностей символов, представляющих собой изображение чисел и осуществляется перекодировка в двоичное представление чисел в соответствии с их типом (целые,  с плавающей точкой) и размещение в нужном количестве байтов памяти.
2. Явное преобразование данных путем вызова процедур или функций конкретного языка. Например, в языке Паскаль это делает процедура Str.
3. Неявное преобразование данных, допустимое в некоторых языках, когда в выражении можно смешивать числовые данные и символьные строки, представляющие собой правильное изображение чисел,  например 12.5+"3.7".
0,0(0 оценок)
Ответ:
lyudagrigoreva2
28.01.2022 23:50
В паскале
const
    n = 3;
    k = 3;
var
  i,j:integer;
  a:array[1..n,1..k] of integer;
begin
    for i:=1 to n do
      for j:=1 to k do
    begin
     Writeln('Введите a[',i,',',j,']:');
     readln(a[i,j]);
    end;
  writeln('Исходный массив:');
  for i:=1 to n do
   begin
     for j:=1 to k do
   write('a[':4,i,',',j,']=',a[i,j]);
   writeln;
   end;
  for i:=1 to n do
    for j:=1 to k do
    if i=j then a[i,j]:=0;
  writeln('Полученный массив:');
  for i:=1 to n do
   begin     for j:=1 to k do
   write('a[':4,i,',',j,']=',a[i,j]);
   writeln;
   end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота