nikita125328
03.12.2022 21:35

1. Напишите программу, которая находит в массиве количество элементов, равных максимальному.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
любимая24
24.10.2021 11:07

program raf105;

var fioa2:array[1..20] of string;

fioa1:string;

m1,g1,m2,g2,i,o:integer;

begin

write('Введите сегодняшнюю дату (месяц, год) через пробел: ');

readln(m1,g1);

g1:= g1*12;

m1:= m1+g1;

writeln;

for i:=1 to 20 do

begin

 write(i,'. Введите фамилию, имя, отчество и адрес сотрудника: ');

 readln(fioa1);

 write('   Дата поступления (месяц, год): ');

 readln(m2,g2);

 writeln;

 g2:= g2*12;

 m2:= m2+g2;

 if m1-m2>=36

   then begin

   o:= o+1;

   fioa2[o]:= fioa1;

   end;

end;

writeln('Сотрудники которые проработали не менее трёх лет:');

for i:=1 to o do

writeln(i,'. ',fioa2[i]);

end.

Язык программирования PascalABC

0,0(0 оценок)
Ответ:
Анют2006
24.10.2021 11:07

program raf105;

const

 n= 4; //Размер матрицы (кол-во и длинна строк). Можно менять

var

 a:array[1..n,1..n] of integer;

 asum:array[1..n] of integer;

 i,j,k,sum,kolsum: integer;

 x: boolean;

begin

write('Введите число k (не больше ',n,'): ');

readln(k);

for i:=1 to n do

begin

 writeln;

 writeln('Введите ',n,' чис. ',i,' стр.');

 for j:=1 to n do

   readln(a[i,j]);

end;

writeln;

writeln('Суммы элементов тех строк, в которых первые ',k,' элем. положительные');  

for i:=1 to n do

begin

 x:= true;

 sum:= 0;

 for j:=1 to k do

 begin

   if x and (a[i,j] <= 0)

     then x:= false;

 end;

   if x

   then  

   begin

     for j:=1 to n do

       sum+= a[i,j];

     kolsum+= 1;

     asum[kolsum]:= sum;

     writeln(asum[kolsum]);

   end;

end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота