dyba00ozclh4
28.03.2023 09:16

Реализовать с 3-х циклов: while, repeat, for) составить программу, которая выдавала бы сообщение ‘ true ‘, если последовательность из n целых чисел, вводимых с клавиатуры, является возрастающей

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
LeylaL11
02.10.2020 14:34
Это реализовано с цикла for:

Program p1;
Var a1,a2,k,i:integer;
Begin
Write('Введите число: ');
Readln(a1);
For i:=0 to 1 do   
Begin   
Write('Введите число: ');   
Readln(a2);   
if a2>a1 then    
k:=k+1;   
a1:=a2;   
End;
if k=2 then 
Writeln('Эта последовательность является возрастающей') else
Writeln('Эта последовательность не является возрастающей');
End.

Это реализовано с цикла while:

Program p2;
Var a1,a2,k,i:integer;
Begin
Write('Введите число: ');
Readln(a1);
While i<>2 do   
Begin   
Write('Введите число: ');   
Readln(a2);   
if a2>a1 then    
k:=k+1;   
a1:=a2;   
i:=i+1;   
End;
if k=2 then Writeln('Эта последовательность является возрастающей') else Writeln('Эта последовательность не является возрастающей');
End.

Это реализовано с цикла repeat:

Program p3;
Var a1,a2,k,i:integer;
Begin
Write('Введите число: ');
Readln(a1);
repeat   
Begin   
i:=i+1;   
Write('Введите число: ');   
Readln(a2);   
if a2>a1 then    
k:=k+1;   
a1:=a2;   
End;
until i=2;
if k=2 then 
Writeln('Эта последовательность является возрастающей') else
Writeln('Эта последовательность не является возрастающей');
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота