Aleksandra231v
08.04.2021 07:22

Напишите программу для робота, рисующего узор меандр ( )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
karrr123
13.01.2021 23:41
//Pascal
  var a,b, I, maxsumm, max : integer;
 
  function summdel(x:integer):integer; //результат - сумма делителей х
  var k,sum:integer;
  begin
    sum:=0;
    for k := 1 to x div 2 + 1 do
      if x mod k = 0 then sum:= sum+k;
    summdel:=sum;
  end;
 
  begin
   writeln('Введите границы a,b ');
   readln(a,b);
    maxsumm := 1;
    max := 1;
    for i := a to b do
     begin
        if summdel(i) > maxsumm then
          begin maxsumm:= summdel(i);
            max := i;
          end;
     end;
     writeLn('Максимальная сумма делителей - ', maxsumm, ' число - ',max)
  end.
0,0(0 оценок)
Ответ:
gas2013
05.03.2021 13:47
#include <iostream>using namespace std; int main(){     char str [] = "dd yhd yw dcjkayt dvqv auyj fbajk dyusdv sddw";     int k = 9; //position     int before=  0, after = 0, space = 0;                         for(int i = 0; i <= k; i++){             if(str[i] == ' '){                 space++;             }         }         if(str[k] != ' '){       for(int i = k + 1; str[i]; i++){         if(str[i] == ' ' || str[i] == '\0'){             after = i;                         break;                 }         }         for(int j = k - 1; j >= 0; j--){         if(str[j] == ' ' || j == 0){             before = j;                         break;                 }     }         cout<<space + 1<<" slovo ";         for(int i = before; i < after; i++)         cout<<str[i];         }         else cout<<space<<" slovo"; return 0; }
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота