1234567890857
24.05.2020 04:13

Составить программу, которая будет считывать введённое десятизначное число. после чего, каждую цифру этого числа необходимо вывести в новой строке. использовать нужно арифметические операции с целыми и вещественными числами. на python.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Yulia221
21.03.2022 03:57

Шаг 1.

В алфавите, согласно условию задачи, ровно 15 символов.

Шаг 2.

Давайте посмотрим, сколько нужно минимум выделить бит на 1 символ из алфавита, состоящего из 15 символов.

Если бы мы выделили 1 бит информации, то он бы смог закодировать 1 символ алфавита, состоящего не более чем из 2 символов. А у нас их 15 Значит, 1 бита мало.

Если выделить 2 бита, то закодировать можно символ в алфавите максимум из 4 символов. Мало.

Если выделить 3 бита, то закодировать можно символ в алфавите максимум из 8 символов. Мало.

Если выделить 4 бита, то закодировать можно символ в алфавите максимум из 16 символов. Достаточно.

Значит, для кодирования 1 символа данного алфавита достаточно 4 бит.

Шаг 3.

1 пароль состоит из 15-ти символов.

1 символ "весит" 4 бита.

Значит, 15 символов будут "весить" 15х4=60 бит.

Шаг 4.

1 пароль по условию кодируется минимально возможным целым количеством байт.

Сколько байт нужно для хранения пароля из 60 бит?

7 байт мало, так как 7 байт = 7х8 = 56 бит.

8 байт — в самый раз: 8 байт = 8х8=64 бита.

Следовательно, для хранения одного пароля нужно 8 байт.

Шаг 5

Один пароль "весит" 8 байт.

У нас — 20 пользователей (и 20 паролей соответственно).

Следовательно, они "весят" 8х20 = 160 байт.

Шаг 6

Выделено было 400 байт под пароли.

Чисто на хранение, согласно п.5, было использовать 160 байт.

Значит, осталось на дополнительную информацию300-160=140 байт.

Шаг 7

140 дополнительных байт имеется подо все пароли.

Всего паролей — 20.

Значит, под каждый дополнительно выделяется 140/20=7 байт.

ответ: по 7 байт дополнительно выделено для хранения одного пароля.

Объяснение:

0,0(0 оценок)
Ответ:
LuckyZhenya
18.06.2020 08:48

ответ:1 2 3 4 5 6 7 8 9 11 12 15 22 24 33 36 44 48 55 66 77 88 99 111 112 115 122 124 126 128 132 135 144 155 162 168 175 184 212 216 222 224 244 248 264 288 312 315 324 333 336 366 384 396 412 424 432 444 448 488 515 555 612 624 636 648 666 672 728 735 777 784 816 824 848 864 888 936 999

Объяснение:var i,j:Integer;

begin

i:=1;

while i<1000 do begin

j:=i;

while j>0 do begin

if (j mod 10=0) then j:=-1 else if (i mod (j mod 10)>0) then j:=-1;

if j>0 then j:=j div 10;

end;

if j=0 then write(i,' ');

inc(i);

end;

end.

Не более трёх граней, не значит три грани, поэтому думаю что так должно быть! )

Результат:

1 2 3 4 5 6 7 8 9 11 12 15 22 24 33 36 44 48 55 66 77 88 99 111 112 115 122 124 126 128 132 135 144 155 162 168 175 184 212 216 222 224 244 248 264 288 312 315 324 333 336 366 384 396 412 424 432 444 448 488 515 555 612 624 636 648 666 672 728 735 777 784 816 824 848 864 888 936 999

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота