VovanBah
08.10.2021 11:00

Нужно написать программу на паскале для вывода на экран квадратов чисел от 2 до 10 и вычисления их суммы​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
epifya
15.04.2023 04:22
Program a;  // имя программы
var n:string; // четырехзначное число будем вводить с клавы
var n1, n2, n3, n4, err: integer; // n1 - n4 это цифры числа, например 1234
var sa: double; // среднее арифметическое
Begin // начало
Read( n ); // вводим с клавиатуры число N
Val( n[1], n1, err ); // первая цифра числа N
Val( n[2], n2, err ); // вторая цифра числа N
Val( n[3], n3, err ); // третья цифра числа N
Val( n[4], n4, err ); // четвертая цифра числа N
sa := ( n1 + n2 + n3 + n4 ) / 4;  // находим среднее арифметическое
if ( sa / 2 = Trunc( sa / 2 ) ) and ( sa > 5 ) then Write( sa ); // если оно четное и больше пяти - выдаем значение на экран
End.  // конец
0,0(0 оценок)
Ответ:
kudryashovayantemik
08.01.2022 19:16

a - массив;

sum - сумма элементов массива;

avrg - среднее значение.

Пример алгоритма решения задачи:

Заполняем массив (например, случайными числами).

Переменной sum изначально присваиваем значение 0.

Вычисляем сумму элементов, в цикле перебирая массив и добавляя значение каждого к переменной sum.

Находим среднее арифметическое, путем деления суммы на количество элементов (хранится в константе N).

Выводим на экран весь массив и найденное среднее значение. (Это не обязательно, но необходимо для удобства.)

Снова в цикле перебираем массив. Если очередной элемент больше среднего арифметического, то выводим этот элемент на экран.

const N = 10;

var

a: array[1..N] of integer;

i: byte;

avrg: real;

sum: integer;

begin

randomize;

for i:=1 to N do a[i]:=random(50)+1;

sum := 0;

for i:=1 to N do sum := sum + a[i];

avrg := sum/N;

// весь массив

for i:=1 to N do write(a[i]:3);

writeln;

writeln('Среднее арифм.: ',avrg:4:2);

// больше avrg

for i:=1 to N do if a[i]>avrg then write(a[i]:3);

writeln;

end.

Пример выполнения программы:

7 36 21 48 33 46 7 17 19 41

Среднее арифм.: 27.50

36 48 33 46 41

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота