eldarsorokin2
10.06.2021 21:58

Написать программу, линейной структуры с комментариями. при объявлении переменных используйте объявления комментария: до конца строки. для операции присвоения значений, используйте комментарий: комментарий для любого количества строк. чем отличается комментарий до конца строки написанный на языке паскаль и в программе pascalabc.net.
по длинам двух сторон треугольника и углу между ними найти длину третьей стороны и площадь треугольника.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fsjxjnlsjaCn
17.03.2020 20:21

х=7690 - условие

var x, L, M: integer;

begin readln(x);

L:=0;

M:=0;

while x > 0 do begin

1) L:= L + 1 = 1;

M:= M + x mod 10 = 0;

x:= x div 10 = 7 69;

2) L:= L + 1 = 2;

M:= M + x mod 10 = 9;

x:= x div 10 = 7 6;

3) L:= L + 1 = 3;

M:= M + x mod 10 = 15;

x:= x div 10 = 7 ;

4) L:= L + 1 = 4;

M:= M + x mod 10 = 22;

x:= x div 10 = 0;

end;

writeln(L);

write(M);

end.

L = 4; M = 22

Объяснение:

1)L:= L + 1 = 0 + 1 = 1;

M:= M + x mod 10 = 0 + 0 (остаток) = 0;

x:= x div 10 = 7690 : 10 = 769 (остаток 0 здесь не пишется);

2)L:= L + 1 = 1 + 1 = 2;

M:= M + x mod 10 = 0 + 9 (остаток) = 9;

x:= x div 10 = 769 : 10 = 76 (остаток 9 здесь не пишется);

3)L:= L + 1 = 2 + 1 = 3;

M:= M + x mod 10 = 9 + 6 (остаток) = 15;

x:= x div 10 = 76 : 10 = 7 (остаток 6 здесь не пишется);

4)L:= L + 1 = 3 + 1 = 4;

M:= M + x mod 10 = 15 + 7 (остаток) = 22;

x:= x div 10 = 7 : 10 = 0 (остаток 7 здесь не пишется);

0,0(0 оценок)
Ответ:
YTO4KA1337
24.01.2021 04:20
ответ:

1) 5

2) 0

3) 1

Объяснение:1) s:=0; for i:=10 downto 6 do s:=s+1;

Переменная s изначально равна 0. Потом идёт цикл от 10 вниз до 6, который каждый раз будет прибавлять к s единицу (s[новая] = s[старая] + 1). Цикл от 10 до 6 включительно, то есть он буде выполнятся 10-6+1=5 раз (+1 т.к. включительно). Получается мы 5 раз прибавляем к нулю 1. ответ: 0 + 1*5 = 5.

2)s:=0; for i:=8 to 3 do s:=s+1;

Переменная s изначально равна 0. Потом идёт цикл от 8 до 6, который выполнятся не будет, так как 8>6, и увеличиваясь на 1 каждый раз, он никогда не дойдет до 6. Для работы необходимо писать downto вместо to, то есть вниз до. Однако такового тут нет, поэтому цикл не выполняется и переменная s остаётся 0. ответ: 0.

3)s:=1; for i:=2 downto 10 dо s:=s+1;

Переменная s изначально равна 1. Потом идёт цикл от 2 вниз до 10, который выполнятся не будет, так как 2<10, и уменьшаясь на 1 каждый раз, он никогда не дойдет до 10. Для работы необходимо писать to вместо downto, то есть до, а не вниз до. Однако такового тут нет, поэтому цикл не выполняется и переменная s остаётся 1. ответ: 1.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота