блабла70
13.03.2022 00:39

Заранее !
1
переменные и описаны в программе как целочисленные. определите значение переменной после выполнения следующего фрагмента программы:
x : = 432;
y : = div(x,100);
x : = mod(x, 100) * 10
x : = x + y

2
определите значение переменной после выполнения следующего фрагмента программы, в котором и – переменные вещественного (действительного) типа.
a : = 5
b : = 5 – 5 * a
b : = b / 2 * a

3
определите значение переменной после выполнения следующего фрагмента программы:
a : = 7
a : = a – 4
b : = –a
c : = –a + 2 * b

4
определите значение переменной после выполнения следующего фрагмента программы:
a : = 2
b : = 2 + 4
b : = 1 – b
c : = –b + 3 * b

5
определите значение суммы целочисленных переменных и после выполнения фрагмента программы:
x : = 4 + 8 * 3 ;
y : = ( x mod 10 ) + 15;
x : = ( y div 10 ) + 3

6
определите значение переменной после выполнения следующего фрагмента программы:
a : = –3 ;
b : = a + 3 ;
b : = 1 – b ;
c : = –b + 3 * a ;

7
определите значение переменной после выполнения следующего фрагмента программы:
a : = 5 ;
a : = a + 6 ;
b : = –a ;
c : = –a – 2 * b ;

8
определите значение переменной после выполнения следующего фрагмента программы:
a : = –5 ;
a : = a – 4 ;
b : = –a ;
c : = –a + 2 * b ;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Danaaad
21.05.2020 10:27

1-ші буын машиналарының элементарлы базасы – электронды вакуумды шамдар

2-ші буын машиналарының элементарлы базасы – транзисторлар

3-ші буын машиналарының элементарлы базасы – кіші интегралды схемалар

4-ші буын машиналарының элементарлы базасы – үлкен интегралды схемалар

5-ші буын машиналарының элементарлы базасы – өте үлкен интегралды схемалар

 1642 жылы француз математигі Блез Паскаль он тоғыз жасында дүние жүзінде бірінші рет қосу машинасы деген атпен белгілі, жетектер мен дөңгелектерден түратын механикалық есептеу машинасын қүрастырды.

1761 жылы ағылшын Д.Робертсон жүгіртпесі бар навигациялық есептеулер жүргізуге арналған логарифм сызғышын жасады. Мүндай қүрал жасау идеясын 1660 жылдары Исаак Ньютон ұсынған болатын.

1833 жылы ол бағдарлама арқылы басқарылатын "Аналитикалық машина" жобасын жасады. Бүл машинада қазіргі компьютерлерде бар барлық негізгі қүраушылар: бастапқы сандар мен аралық нәтижелерді сақтауға арналған жад, жадтан алынған сандармен амалдар орындайтын арифметикалық қүрылғы, берілген бағдарлама бойынша есептеу барысын қадағалап отыратын басқару қүрылғысы, деректерді енгізу мен оларды басып шығару құрылғысы болып табылады.

1945 жылы венгер текті көрнекті американ математигі Джон фон Нейман ұсынған болатын. Нейман бойынша негізгі бөліктер басқару құрылғысы (БҚ) және арифметикалық-логикалық құрылғы (АЛҚ) жады, сырқы жады, енгізу және шығару құрылғылары болып табылады.

0,0(0 оценок)
Ответ:
sofiika17
21.05.2020 10:27

2-ое задание:

#include <iostream>

int main() {

int number;

std::cout << "Введите число: " << std::endl;

std::cin >> number;

if (number > 0)

 std::cout << "Положительное" <<std::endl;

else if (number < 0)

 std::cout << "Отрицательное" << std::endl;

else

 std::cout << "Ноль" << std::endl;

return 0;

}

1-ое задание:

#include <iostream>

int main() {

double dollars, grivnas;

std::cout << "Введите кол-во долларов: " << std::endl;

std::cin >> dollars;

grivnas = dollars * 28.3;

std::cout << dollars << " доллар-(а, ов) в гривнах " << grivnas << std::endl;

return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота