StasSav06
09.04.2022 13:05

1) Составьте программу, в которой продавец спросит у Вас, сколько шоколадок и по какой цене Вы собираетесь купить, и назовет Вам стоимость вашей
покупки. 2) Составьте программу, в которой компьютер запросит у Вас ввести любое
число от 1-9. После выведет таблицу умножения на указанное число

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Thandey
25.07.2020 00:08

Объяснение:

Позиционная систе́ма счисле́ния (позиционная нумерация) — система счисления, в которой значение каждого числового знака (цифры) в записи числа зависит от его позиции (разряда).

Системы счисления в культуре

Индо-арабская

Арабская

Тамильская

Бирманская

Кхмерская

Лаосская

Монгольская

Тайская

Восточноазиатские

Китайская

Японская

Сучжоу

Корейская

Вьетнамская

Счётные палочки

Алфавитные

Абджадия

Армянская

Ариабхата

Кириллическая

Греческая

Грузинская

Эфиопская

Еврейская

Акшара-санкхья

Другие

Вавилонская

Египетская

Этрусская

Римская

Дунайская

Аттическая

Кипу

Майяская

Эгейская

Символы КППУ

Позиционные

2, 3, 4, 5, 6, 8, 10, 12, 16, 20, 60

Нега-позиционная

Симметричная

Смешанные системы

Фибоначчиева

Непозиционные

Единичная (унарная)

0,0(0 оценок)
Ответ:
9854123g
28.02.2023 08:09
Как я понял, вам необходимо было исправить ошибки в коде. Если это так, то
Program ddd;
var tg, f:real;
x:integer;
begin
readln (x);
tg := sin(x)/cos(x);
if x<=-3.14 then f:=ln(cos(5*x)-2*x)+1;
if x>-3.14 then f:=0.35*tg*(0.1*x)-exp(ln(2*2.7)*(-0.1*x));
writeln (f);
end.

Обратите внимание, что вещественные числа указываются посредством точки, а не запятой (не "0,1", а "0.1"). Функция cos должна принимать какой-либо аргумент, ибо сама по себе она не представляет никакого значения (f:=ln(cos*(5*x)-2*x)+1; -- здесь вы cos * на выражение, что неверно). Приравнивать переменные одих типов к значению других -- ошибка (f:integer; - значение типа интеджер. ln(cos(5*x)-2*x)+1; - функция ln возвращает значение типа real. Следовательно, f не может присвоить возвращаемое значение функции ln).
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота