сонечка3332002
11.06.2020 04:47

Написать программу по информатике (можно на pascal или на c++)!
количество минимумов
найдите количество минимальных элементов в последовательности.

входные данные

вводится натуральное число n, а затем n чисел.

выходные данные

выведите количество минимальных элементов.
например :
мы вводим :
3
21
11
4
на выходе получаем : 1​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
overlordcfg
11.10.2020 00:04

#include <iostream>

using namespace std;

void main(){

int N, a, min, cmin;

cin >> N;

cin >> min;

cmin = 1;

for(int i=1; i<N;i++){

cin >> a;

if(min==a)

cmin++;

if(min>a){

min = a;

cmin = 1;

}

}

cout << cmin;

}

0,0(0 оценок)
Ответ:
TuyaChimitova
11.10.2020 00:04

PascalABC.NET (Обязательно .NET, используется библиотека классов .NET)

begin

 var list: List<integer> := new List<integer>;

 var N := ReadInteger();

 for var i := 1 to N do

 begin

   list.Add(ReadInteger());

 end;

 

 list.Where(x -> x = list.Min()).Count.Println();

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота