34224253
07.11.2021 18:39

Написать программу просмотра сюжета фильма
необходимо будет реализовать следующие функции:
1) список фильмов не менее 5 штук
2) выбор фильма открывается его сюжет

35 с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Мадина0911
07.05.2020 20:52
Проанализируем работу цикла:
i=2
Mas(i) - Mas(i-1) > m ⇒ Mas(2) - Mas(1) > m ⇒ 5-10 > 2 ⇒ -5 > 2 ⇒ нет
i=3
Mas(i) - Mas(i-1) > m ⇒ Mas(3) - Mas(2) > m ⇒ 7-5 > 2 ⇒ 2 > 2 ⇒ нет
i=4
Mas(i) - Mas(i-1) > m ⇒ Mas(4) - Mas(3) > m ⇒ 3-7 > 2 ⇒ -4 > 2 ⇒ нет
i=5
Mas(i) - Mas(i-1) > m ⇒ Mas(5) - Mas(4) > m ⇒ 9-3 > 2 ⇒ 6 > 2 ⇒ да; k=1
i=6
Mas(i) - Mas(i-1) > m ⇒ Mas(6) - Mas(5) > m ⇒ 2-9 > 2 ⇒ -7 > 2 ⇒ нет
i=7
Mas(i) - Mas(i-1) > m ⇒ Mas(7) - Mas(6) > m ⇒ 4-2 > 2 ⇒ 2 > 2 ⇒ нет

ответ: k=1
0,0(0 оценок)
Ответ:
Заяц699
15.05.2022 18:48
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger;
  var (s,d,e):=(n div 100, (n div 10) mod 10, n mod 10);
  Writeln('Cотни ',s,', десятки ',d,', единицы ',e);
  Writeln('Сумма цифр ',s+d+e,', их произведение ',s*d*e);
  Writeln('Справа налево: ',100*e+10*d+s);
  Writeln('Перестановка сотен в конец: ',100*d+10*e+s)
end.

Пример
328
Cотни 3, десятки 2, единицы 8
Сумма цифр 13, их произведение 48
Справа налево: 823
Перестановка сотен в конец: 283
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота