angelinashushi
20.02.2022 19:40

Напишите программу, которая определяет, что за атом (или ион) образовался. если количество электронов не равно количеству протонов, то образовался ион. в противном случае — нейтральный атом. название элемента определяется количеством протонов. изотоп — по числу нейтронов. формат ввода вводятся 3 целых числа, обозначающие количество электронов, протонов и нейтронов, образующих атом, каждое с новой строки. формат вывода на первой строке — атом или ион. далее — название элемента (в данном случае только водород или гелий). изотоп (см. таблицу). возможные варианты:

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

===== PascalABC.NET =====

begin

 // неверные варианты вызовут ошибку при выполнении

 var mp := Arr('водород', 'гелий');

 var mn := Arr('протий','дейтерий','тритий','гелий-3','гелий-4');

 var (e, p, n) := ReadInteger3;

 Writeln(e = p ? 'атом' : 'ион');

 Writeln(mp[p - 1]);

 Writeln(p = 1 ? mn[n] : mn[n + 2])

end.


Напишите программу, которая определяет, что за атом (или ион) образовался. если количество электроно
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота