Shkolnik228007
11.10.2022 19:58

Напишите программу, для вывода массива,

состоящего из 50 элементов, наименьший из которых будет

равен 5.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
//Pascal ABC.NET v3.0 сборка 1111

var
 i,a,b:integer;
 ar:array[1..10] of integer;

 procedure oddDec(var a,b:integer);  //подпрограмме переданы аргументы a и b
//процедура для вычитания в нечётном элементе
begin;
a:=a-b;
end;

procedure NotoddInc(var a,b:integer); //подпрограмме переданы аргументы a и b
//процедура для сложения в чётном элементе
begin;
a:=a+b;
end;

begin
randomize;
readln(a); //ввод a
readln(b); //ввод b
writeln('Array:');
for i:=1 to 10 do //весь массив
 begin;
  ar[i]:=random(-20,80); //случайные числа от -20 до 80 включительно
  write(ar[i]:4); //вывод
  if odd(i) then oddDec(ar[i],b) else NotoddInc(ar[i],a);
  {если нечётное, то первая процедура, иначе вторая. Обращаю внимания на то, что элементы меняются сразу после вывода}
 end;
writeln;
writeln('Final array:'); //вывод получившегося массива
for i:=1 to 10 do
write(ar[i]:4);
end.

Пример ввода:
20
10
Пример вывода:
Array:
  10  16   0  60  23   4  22 -20   4  55
Final array:
   0  36 -10  80  13  24  12   0  -6  75  
0,0(0 оценок)
Ответ:
12СоловьёваАнна
19.03.2021 07:57

Для разделения целой и дробной частей десятичной дроби использовать запятую.

Вводить отрицательные числа со знаком минус или взять число в скобки.

Для обозначения процентов после числа вводить символ "%".

Обычную дробь нужно вводить, указывая и отделяя её от дробной пробелом.

Обозначение единиц измерения после чисел не вводится, только если это не денежные единицы.

перевод:

Для поділу цілої та дробової частин десяткового дробу використовувати кому.

Вводити негативні числа зі знаком мінус або взяти число в дужки.

Для позначення відсотків після числа вводити символ "%".

Звичайну дріб потрібно вводити, вказуючи і відокремлюючи її від дробу прогалиною.

Позначення одиниць виміру після чисел не вводиться, тільки якщо це не грошові одиниці.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота