irina20042005
21.09.2022 01:43

Нужно решить в паскале. умоляю, от этого зависит итоговая оценка!
напишите программу, которая сортирует по возрастанию все элементы массива с нечётными номерами, а все элементы с чётными номерами – по убыванию. нумерация элементов массива начинается с единицы.

входные данные

первая строка содержит размер массива  n  . во второй строке через пробел   n  чисел – элементы массива. гарантируется, что  0 <   n  ≤ 1  .

выходные данные

программа должна вывести все элементы отсортированного массива в одну строку, разделив их пробелами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lilia55590
04.08.2020 06:25
{массив заполняется случайным образом положительными и отрицательными элементами. Находятся отрицательные элементы на главной диагонали и если они есть, то находится их сумма и количество. После этого проверяется, если есть отрицательные элементы на главной диагонали, то выдается среднее арифметическое, если нет, то на экране ответ "нет отриц"}
const
m=100;
var
a:array[1..m,1..m]of integer;
i,j,S,n,k: integer;
begin
Readln(n);
    for i:=1 to n do
        begin
             writeln;
                 for j:=1 to n do
                      begin
                            a[i,j]:=random(100)-50;
                             write(a[i,j]:4);
                                  
                      end;
         end;
for i:=1 to n do
  if a[i,i]>0 then
        begin
           s:=s+a[i,i];
           k:=k+1;
       end;
writeln;
 if   k<>0 then
      writeln('SR=', s/k)
 else
       writeln('Net <0');
end.
0,0(0 оценок)
Ответ:
znani5
04.08.2020 06:25

bool ok1(int a, int b, int c){

  return (a+b > c && a+c > b && b+c > a) && min(a,min(b,c)) > 0;

}

bool ok2(int a, int b, int c){

  return ok1(a,b,c) && (a == b || a == c || b == c);

}

signed main(){

  const int n = 3, m = 7;

  int arr[n][m];

  for(int i = 0; i < n; i++)

      for(int j = 0; j < m; j++)

          cin >> arr[i][j];

  vector<int> ans;

  for(int j = 0; j < m; j++)

      if(ok2(arr[0][j],arr[1][j],arr[2][j]))

          ans.push_back(j+1);

  cout << ans.size() << "\n";

  for(auto i: ans)

      cout << i << " ";

}

Подробнее - на -

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота