lianagabrielya
08.12.2022 02:22

Реьят напишите программу вычисления выражения: s=1! +2! +3! ++n! используйте функцию вычисления факториала

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Вадим98913
23.09.2020 08:54
Var n,i,s:integer;
function fact(k:integer):integer;
var j,f:integer;
begin
f:=1;
for j:=1 to k do f:=f*j;
fact:=f;
end;
begin
write('n='); readln(n);
s:=0;
for i:=1 to n do s:=s+fact(i);
writeln('s=',s);
end.

Пример:
n=5
s=153
0,0(0 оценок)
Ответ:
Sijjj777
23.09.2020 08:54
// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
function F(n:Integer):integer:=Range(1,n).Aggregate(1,(i,j)->i*j);

begin
  Writeln(Range(1,ReadInteger('n=')).Select(x->F(x)).Sum);
end.

Тестовые решения:
n= 5
153

n= 10
4037913
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота