0508761681
11.01.2020 02:52

с решением , на паскале:
на вход программе подается три различных целых числа. вывести на экран, как соотносится третье введённое число относительно первых двух: "больше" (если оно больше обоих первых чисел), "меньше" (если оно меньше обоих первых чисел) или "между" (если оно больше одного, но меньше другого). запрещается пользоваться арифметическими операциями. дополнительный получит программа, выполняющая в худшем случае не более 3-сравнений.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
id95874775
27.08.2020 18:52

PascalABC.NET

begin

 var (a, b, c) := ReadInteger3;

 if a > c then

   if b > c then

     Write('меньше')

   else

     Write('между')

 else if b > c then

   Write('между')

 else

   Write('больше')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота