paschprudnikov
04.07.2021 19:39

Напишите программу на языке паскаль.
автомобиль шкода едет со скоростью 180 кмч/ч, автомобиль audi со скоростью 98 км/ч. кто быстрее доберётся до города в из города а?
, !

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Maxi2007
06.02.2023 19:40

Шапка

Форма блока шапки

Именно с шапки начинается любой скрипт. Блок шапка — это некое событие (например щелчок по зелёному флагу), которое вызвано взаимодействием пользователя с программой. Они скруглены сверху и имеют выступ снизу для прикрепления других блоков. Существуют 7 блоков шапок, 6 из которых в категории события, 1 в категории управления.

Обычный блок

Форма обычного блока

Обычные блоки – это блоки команд. Они прикрепляются сверху выступом и прикрепляют снизу выступом вовнутрь, то есть остальные блоки могут быть помещены как сверху, так и снизу обычных блоков. Всего насчитывают 71 такой блок – это самая большая категория блоков.

Логический блок

Форма логического блока

Логические блоки – это условия, определяющие правильно или ложно заданное условие. Спроси своего друга «2 умножить на 2 будет 4?» и попроси его ответить только «Да» или «Нет». Твой друг станет этаким логическим блоком. Они имеют форму шестиугольника и всего насчитывается 12 таких блоков.

Репортёр

Форма блоков репортёров

Блоки репортёры дают какие-либо значения. Они могут быть как числами, так и строками. Например, спроси друга: "Сколько будет 2 + 2?". Он ответит "4". Твой друг станет этаким репортёром. Кстати, репортёрами могут быть и переменные. Форма репортёров – закруглённые прямоугольники. Всего насчитывают 30 таких блоков, не считая репортёров переменных и списков.

Обвивающий блок

Форма обвивающего блока

Обвивающие блоки – это блоки повторения или блоки условий. Их насчитывают всего 5 и их можно найти во вкладке "Управление". Имеют выступ вовнутрь сверху и простой выступ внутри и снаружи.

Закрывающий блок

Форма закрывающего блока

Закрывающие блоки заканчивают скрипт или все процессы. Имеют выступ вовнутрь сверху и не могут иметь прикреплённых блоков снизу. Всего существует 2 закрывающих блока, и оба находятся во вкладке "Контроль".

Категории блоков

Объяснение:

0,0(0 оценок)
Ответ:
221967
11.12.2022 05:20

Задание 1:

var i:integer;

begin

   for i:=1 to 20 do writeln('2^',i,'=',exp(i*ln(2)):0:0)

end.

Задание 2:

Мало деталей...N чисел вводятся вручную или они генерятся автоматически рандомно?

var i,min,n,x:integer;

begin

   min:=9999;

   write('Количество чисел: '); readln(n);

   for i:=1 to n do begin

       write('Введите ',i,'-е число: '); readln(x);

       if x < min then min:=x

   end;

   write('Минимальное из введённых чисел равно ', min);

end.

Задание 3:

var i,x:integer;

   chk:boolean;

begin

   chk:=True;

   write('Введите натуральное число: '); readln(x);

   for i:=2 to x-1 do begin

       if x mod i = 0 then begin

           chk:=False;

           break;

       end;

   end;

   if chk = True then write('Введённое число является простым.')

   else write('Введённое число не является простым.');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота