sizikova2004
24.03.2021 01:22

Нужно написать программу на с.
задан непустой текст длиной до 255 символов. выполнить над
каждым словом текста следующие действия. если слово начинается и заканчивается на один и тот же символ, то изъять из слова все остальные вхождения этого символа, иначе удвоить каждый символ, который является латинским согласной буквой. гарантируется, что после добавления символов длина строчки не будет превышать 255 символов.
. сколько не пробовал - не получается.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
мпрлкт
21.04.2022 10:19
Program z1; 
Var i,n,a,b,c:integer;     
 m: array [1..1000] of integer;
Begin 
write('Введите кол-во чисел - '); 
readln(n);   
randomize;   
a:=0;   b:=0;   c:=0; 
 for i:=1 to n do 
begin   
m[i]:=random(100)-50;   
 write (m[i],' ');  end;    for i:=1 to n do    if (m[i]=0) then a:=a+1;      for i:=1 to n do    if (m[i]>0) then b:=b+1;      for i:=1 to n do    if (m[i]<0) then c:=c+1;  writeln;  writeln ('Кол-во нулей - ',a);  writeln ('Кол-во положительных чисел - ',b);  writeln ('Кол-во отрицательных чисел - ',c);End.
0,0(0 оценок)
Ответ:
Ahamad
21.04.2022 10:19
Program z1;  Var i,n,a,b,c:integer;      m: array [1..1000] of integer;Begin  write('Введите кол-во чисел - ');  readln(n);   randomize;   a:=0;   b:=0;   c:=0;  for i:=1 to n do  begin    m[i]:=random(100)-50;    write (m[i],' ');  end;    for i:=1 to n do    if (m[i]=0) then a:=a+1;      for i:=1 to n do    if (m[i]>0) then b:=b+1;      for i:=1 to n do    if (m[i]<0) then c:=c+1;  writeln;  writeln ('Кол-во нулей - ',a);  writeln ('Кол-во положительных чисел - ',b);  writeln ('Кол-во отрицательных чисел - ',c);End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота