Golinskaya2002a
05.05.2022 21:09

Составьте программу, которая по выбору пользователя возводит введенное с клавиатуры целое число в квадрат, определяет его абсолютную величину или извлекает квадратный корень числа. в программе следует предусмотреть вывод сообщений об ошибке, если пользователь попытается извлечь квадратный корень из отрицательного числа. использовать стандартные функции abs, sqr, sqrt.
пы.сы.составить в pascal

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fernandus
03.06.2022 02:17
P.S.

Тернарная операция в C++ - это выражение вида (b ? x : y) (где b - логическое выражение, а x и y - одного типа). Она вернёт x, если выражение b истинно, и y, если b ложно.


Решение

В приложении расписаны координаты некоторых клеток, а также помечены точками те, которые по цвету отличаются от не помеченных. Если поискать, что у них общего, можно обнаружить, что у "невыколотых" клеток сумма координат по горизонтали и вертикали - чётная. Это "свойство" и используем для определения цвета клетки.


Код

#include <bits/stdc++.h>

using namespace std;

int main() {

 int x1, y1, x2, y2;

 cin >> x1 >> y1 >> x2 >> y2;

 cout << ((x1 + y1) % 2 == (x2 + y2) % 2 ? "YES" : "NO") << endl;

 return 0;

}



На с++ с тернарной операцией поле шахматной доски определяется парой натуральных чисел, каждое из ко
0,0(0 оценок)
Ответ:
olechka162
03.06.2022 02:17

Давай сравним все 4 числа между собой, найдём максимальное и вычтем из него N.


Код

#include <bits/stdc++.h>

using namespace std;

int main() {

   int a, b, c, d, n;

   cin >> a >> b >> c >> d >> n;

   if (a > b && a > c && a > d)

       a -= n;

   else if (b > a && b > c && b > d)

       b -= n;

   else if (c > a && c > b && c > d)

       c -= n;

   else d -= n;

   cout << a << " " << b << " " << c << " " << d << endl;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота