33333ц
28.11.2021 22:19

Составить программу заполнения массива b случайными целыми числами из диапазона 50 до 200. количество чисел 30. (язык dim)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Soonthanyou
24.10.2020 19:17
ответ: 2;
Решение:
1)6 мегапикс. = 6000000 пикс;

2) Пусть x ширина картинки, тогда y ее длина.
Уравнение: X * 1,5Y = 6000000

3) Находим отношение (1,5). Получается уравнение: 6000000 / X * Y = 1,5;

4)Затем по пропорции находим произведение X и Y. Получилось: 6000000 / 1,5 = X * Y; 4000000 = X * Y;

5)Здесь картинка получается квадратом (условно, без уменьшение ширины, без 1,5);

6)Отсюда можно сделать вывод, что умножение Y на 1,5 дает ответ 3, а разрешение картинки равно: X * Y = 2 * 3 = 6 мегапикс.

P. S. Извиняюсь, что немного муторно, но Информатика есть инорматика...
0,0(0 оценок)
Ответ:
vitya123567
05.02.2022 07:54
На второе задание:
program sortArray;
var
 arrayA:array[1..50] of real;
 bufR:real;
 n,ci,cIi,stOt,most:byte;
begin
 readln(n); for ci:=1 to n do readln(arrayA[ci]);
 for ci:=1 to n-1 do
  begin
  most:=0;
  for cIi:=ci to n do
   if (arrayA[cIi]>=0) and ((arrayA[cIi]<arrayA[most]) or (most=0)) then most:=cIi;    if most<>0 then
   begin
    bufR:=arrayA[ci]; arrayA[ci]:=arrayA[most]; arrayA[most]:=bufR;   
   end   
  else
   begin
    stOt:=ci; break;
   end;
  end;
for ci:=1 to n-stOt do
 begin
  most:=stOt+ci-1;
  for cIi:=stOt+ci to n do
   if arrayA[cIi]>arrayA[most] then most:=cIi;
  bufR:=arrayA[stOt+ci-1]; arrayA[stOt+ci-1]:=arrayA[most]; arrayA[most]:=bufR;   end;
writeln;  for ci:=1 to n do writeln(arrayA[ci]:0:3); readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота