aminyl
15.09.2022 23:15

С

программа «календарь». составить программу оп¬ределения названия года в соответствии со старояпонским календарем. в старояпонском календаре был принят 60-летний цикл, состоящий из пяти 12-летних подциклов. в программе необходимо реализовать алгоритм определения названия года при условии, что 1984 г. – год зеленой крысы принят в качестве начала очередного цикла.
цикл цветов: 1 – зеленый, 2 – красный, 3 – желтый, 4 – белый, 5 – черный.
цикл животных: 1 – крыса, 2 – корова, 3 – тигр, 4 – заяц, 5 – дракон, 6 – змея,
7 – лошадь, 8 – овца, 9 – обезьяна, 10 – курица, 11 – собака, 12 – свинья.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
narminanarminaovsozg
24.01.2023 07:36

1 Задание

Вводим переменные x и y.

Переменная k -количество равно нулю и i равно единице.                            

         repeat

         k:=k+1;

         i:=i+2;

      until i>=(x+y)

2 Задание

Program SpecialHappyTickets;


var

 i, j, k, l, m, n, s: integer;


begin

 s := 0;

 for i := 0 to 9 do

   for j := 0 to 9 do

     for k := 0 to 9 do

       for l := 0 to 9 do

         for m := 0 to 9 do

           for n := 0 to 9 do

             if (i + j + k) = (l + m + n) then

               if i + j + k = 13 then s := s + 1;

 Writeln(s)

end.


program SpecialHappyTickets;


var

 i, j, k, l, m, n, s: integer;


begin

 s := 0;

 for i := 0 to 9 do

   for j := 0 to 9 do

     for k := 0 to 9 do

       for l := 0 to 9 do

         for m := 0 to 9 do

           for n := 0 to 9 do

             if (i + j + k) = (l + m + n) then

               if i + j + k = 13 then s := s + 1;

 Writeln(s)

end.

Результат выполнения программы:

5625

3 Задание

var a,i:integer; b:boolean;

begin

a:=1;

repeat

b:=true;

for i:=2 to 6 do

 b:=b and (a mod i = (i-1));

if not b then a:=a+1;

until b;

writeln('a = ',a);

end.

Результат:

a = 59

4 Задание

Program summa;

var a,x:integer; 

i,s:integer;

begin 

writeln('введите целое число');

 readln( a );

 x:=a; 

s:=0; 

while ( x<>0 ) do  begin   s := s + (x mod 10); 

 x := x div 10; 

end;

writeln( 'Сумма цифр числа ',a,' = ', s );

end.

5 Задание

1. Количество нулей в конце числа равно количеству десяток в этом числе. Поскольку число 10 состоит из двух простых множителей: 2 и 5, то в конце числа будет столько же нулей, сколько пятерок в числе (т. к. двоек в 100! намного больше).

  2. Найдем число пятерок в 100! Среди чисел от 1 до 100:

1) 5^3 - нет;

2) 5^2 - 25; 50; 75 и 100 - 4 числа;

3) кратных 5: 100/5 = 20 чисел.

6 Задание

const n=8;

var a:array[1..n] of integer;

   i,z:integer;

begin

z:=1;

for i:=1 to n do

begin

 a[i]:=z*(2*i-1);

 write(a[i],' ');

 z:=-z;

end;

end.

7 Задание

var i,n:integer;

begin

write ('количество раз');

readln(n);

for i:=1 to n do

 write(0);

end.

0,0(0 оценок)
Ответ:
SmilLl
21.02.2022 17:44

Рекламное агентство «Нью-Тон Екатеринбург» предлагает своим клиентам размещение рекламы внутри салонов транспорта в Екатеринбурге на эксклюзивных, особо выгодных условиях в рамках трех пакетных предложений – «Все за 110», «Все за 220» и «Все за 330». Размер предоставляемой скидки составляет 30%.Пакеты действуют с 1.07.2014 по 31.08.2014. Агентство является официальным оператором ЕМУП «Трамвайно-троллейбусное управление».

Арифметика пакетных предложений предельно проста: вы можете разместить рекламу внутри трамваев и троллейбусов сроком на 1, 2 или 3 месяца, задействовав 708 транспортных средств и выбрав в подарок одну или несколько опций в зависимости от конкретного пакета. Среди них− размещение листовок на остановках транспорта или в подъездах (на информационных стендах), размещение рекламы в метрополитене города, на автобусах, в лифтах жилых домов или стикеры в метро (формат А4).

Нельзя не отметить неоспоримые преимущества рекламы в транспорте, в числе которых низкая стоимость рекламного контакта (меньше 1 копейки), широкий охват аудитории (ввиду сильной развитости транспортной сети Екатеринбурга пассажиропоток в городе составляет 11,5 миллионов человек) и возможность географического таргетинга.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота