катя5085
08.04.2022 04:35

Написать программу, которая осуществляет вывод одномерного массива, поиск максимального значения и выводит его индекс в этом массиве.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
anait87
20.07.2020 09:52
Var i,imax,amax:integer;
a:array[1..10] of integer;
begin
writeln('Введите числа');
for i:=1 to 10 do
begin
write('a[',i,']= ');
read(a[i]);
end;
a[1]:=amax;
imax:=1;
for i:=1 to 10 do
if amax<a[i] then
begin
amax:=a[i];
imax:=i;
end;
writeln('Исходный массив');
for i:=1 to 10 do
write(a[i]:4);
writeln;
writeln('Элемент под номером ',imax,' имеет максимальное значение равное ',amax);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота