Аngel11
15.10.2021 23:08

Нужно написать программу на языке си. заранее !
дан двумерный массив a, размером (m x n). заполнить одномерный массив, найдя среднее положительных элементов в каждом столбце матрицы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
posaliza170401
16.06.2021 13:38

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

   int number, coun = 0, d, first, last;

   double pwr;

   setlocale(LC_ALL, "Russian");

   cout << "Поменять первую и последнюю цифры числа>" << endl;

   cout << "Введите число: ";

   cin >> number;

   d = number;

   while (d > 0)

   {

       d /= 10;

       coun++;

       cout << "count = " << coun << endl;

   }

   pwr = pow(10, coun-1);

   //к примеру число равно 321

   //first = 3

   //last = 1

   //number = 32

   //number = 323

   //number = 23

   //number = 123

   first = number / (int)pwr;

   last = number % 10;

   number /= 10;

   number = number * 10 + first;

   number %= int(pwr);

   number += last * int(pwr);

   cout << "Result: " << number << endl;

   return 0;

}

0,0(0 оценок)
Ответ:
anastasiaperova
30.04.2023 02:34

С++14

Код:

#include <iostream>#include <iomanip>#include <string>#include <algorithm> size_t count_char(const std::string& number, char c) {     return std::count(number.begin(), number.end(), c);} bool is_it_more_than(const std::string& number, char a, char b) {    return count_char(number, a) > count_char(number, b);}int main() {    long long k = 4353621ll;    char a = '3';    char b = '4';    std::string number = std::to_string(k);    std::cout << "Number is " << number << std::endl;    std::cout << "a = " << a << std::endl;    std::cout << "b = " << b << std::endl;    std::cout << "Does a appear in Number more often than b: " << std::boolalpha << is_it_more_than(number, a, b) << std::endl;    return 0;}
C++. Дано натуральное число. Верно ли, что цифра a встречается в нем реже, чем цифра b?​
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота