sabinaaslanova
25.09.2020 06:45

Написать программу в паскале котрая расставляет три числа в порядке возрастания

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
darya1122334455667
23.05.2020 17:57

program ttt;
var i,j,a,b,c:integer;
begin
readln(a);
readln(b);
readln(c);

if (a>b) then
if (a>c) then
begin
write(a);
if (b>c) then begin write(b);write(c) end; else begin write(c); write(b);end
end; else

if (b>c) then begin write (b); if(a>c)then begin write(a); write(c);end; else begin write(c); write(a);end; end;
else begin write(c); if(a>b) then begin write(a);write(b)end; else begin write(b); write(a); end;end;

end;

неоптимальный, но понятный алгоритм.
а в другом случае можноо оптимизировать.. как- подумай -;)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота