DEKTG
03.08.2022 11:17

Написать программу подсчета букв е во введенной строке. выполнить на языке си

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
AlsiMaksimowa
28.03.2021 08:57

program z1;

var i,n,s:integer;

a : array [1..100] of integer;

begin

write ('Введите количество элементов n < 100: ');

readln(n);

write ('Массив: ');

for i:= 1 to n do

begin

a[i]:=random (21)-10;

write(a[i]:5)

end;

writeln;

s:=0;

for i:= 1 to n do

if a[i]<0 then s:=s+a[i];

writeln ('s = ',s)

end.

Объяснение:

Ошибки

1) нет названия программы и ; после неё

2) в описании массива 3 точки (надо 2)

3) нет кавычек для ввода текста в первом write

4) нет ; после readln (n)

5) нет : при присваивании i в цикле for i = 1

6) нет форматированного вывода или добавленного разделителя в write(a[i])

7) нет ; после первого end

8) нет ; после s:=0

9) нет кавычек для ввода текста в writeln (s = ,s)

10) нет точки после последнего  end

Условие

for i:= 1 to n do (перебираем весь массив)

if a[i]<0 then s:=s+a[i]; (если элемент меньше 0, то увеличиваем переменную s (сумму) на него)

0,0(0 оценок)
Ответ:
marsik12912
20.07.2022 15:16
Var
 a: array[0..99] of integer;
begin
  //заполняем массив случайными числами
  Randomize();
  for var i:=0 to 99 do a[i]:=random(-100,100);
 
  //а теперь заменяем все отрицательные элементы на ноль
  for var i:=0 to 99 do 
    if (a[i]<0) then a[i]:=0;
end.

Вот второй вариант программы, со вводом с клавиатуры и со сдвигом нулевых элементов в хвост массива
program pr_1;constn = 6;varA: array [1..n] of integer; n1: integer;
beginWrite('введите ');for i := 1 to n doread(A[i]);  n1:=n;  for var i:=n downto 1 do{в цикле просматриваем элементы массива}  begin    if A[i] < 0 then {проверяем, нужно ли удалять i-ый элемент}    begin{если нужно – удаляем i-ый элемент}      for var j := i to n1 - 1 do         A[j] := A[j + 1]; {сдвигаем}       A[n1]:=0;        Dec(n1); {уменьшаем количество элементов}    end;  end;  for var i:=1 to n1 do    write(A[i], ' ');end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота