ulashn
06.03.2020 15:53

Язык программирования c# в visual studio
написать программу, которая выводит на экран квадрат пифагора
– таблицу умножения

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Зайчутка
10.10.2020 14:38

ответ:#include<stdio.h>

int main()

{

int y[10][10];// задаем двумерный массив y 10 строк, 10 столбцов  

  int i,j; // переменные целого типа, отвечающие за строки, столбцы

   for(i=1;i<10;i++) { //цикл по строкам

       for(j=1;j<10;j++){ //цикл столбца

           y[i][j]=i*j; //i это индекс строки, j – индекс столбца

           printf("%6d",y[i][j]); //выводим элементы на экран

       }

       printf("\n"); //\n - перевод на новую строку для корректного отображения нашей таблицы

   }

}

Объяснение:

//i*j происходит перемножение элементов начиная с еденицы, т.е 1*1=1, затем 1*2=2, 1*3=3 и т.д  

//когда j<10 т.е 1*9=9, будем умножать i=2, т.е 2* 1=2, 2*2=4 и т.д

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота