ASkrpt
14.09.2021 06:14

Boolean составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: 1) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр; 2) с�мма цифр данного трехзначного числа n является четным числом; 3) точка с координатами (х, у) принадлежит части плоскости, лежащей между прямыми x = m, x = n (m < n); 4) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа; 5) целое число n является четным двузначным числом; 6) треугольник со сторонами а, b, c является равносторонним; 7) треугольник со сторонами а, b, c является равнобедренным; 8) среди чисел a, b, c есть хотя бы одна пара взаимно противоположных чисел; 9) числа c и b выражают длины катетов одного прямоугольного треугольника, а c и d – другого. эти треугольники являются подобными; 10) даны три стороны одного и три стороны другого треугольника. эти треугольники равновеликие, т.е. имеют равные площади; 11) данная тройка натуральных чисел a, b, c является тройкой пифагора, т.е. c2 = a2 + b2; 12) все цифры данного четырехзначного числа n различны; 13) данные числа x, y являются координатами точки, лежащей в первой координатной четверти; 14) (х1, у1) и (х2, у2) – координаты левой верхней и правой нижней вершин прямоугольника; точка а(х, у) лежит внутри этого прямоугольника или на одной из его сторон; 15) число с является средним арифметическим чисел a и b; 16) натуральное число n является точным квадратом; 17) цифры данного четырехзначного числа n образуют строго возрастающую последовательность; 18) цифры данного трехзначного числа n являются членами арифметической прогрессии; 19) цифры данного трехзначного числа n являются членами прогрессии; 20) данные числа c и d являются соответственно квадратом и кубом числа а; 21) цифра м входит в десятичную запись четырехзначного числа n; 22) данное четырехзначное число читается одинаково слева направо и справа налево; 23) сумма двух натуральных чисел кратна 2; 24) произведение натуральных чисел a и b кратно числу с; 25) сумма двух действительных чисел a и b является целым числом, т.е. дробная часть суммы равна нулю; 26) данное натуральное число а кратно числу b, но не кратно числу с.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Нэтэли11
17.08.2022 14:00
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var a:=ReadLines('m17.txt').JoinIntoString.ToIntegers;
  a.Println;
  var b:=a.Select((x,i)->Rec(x,i)).Where(x->x.Item1<0)
    .Select(x->x.Item2).ToArray;
  if b.Count<>2 then
    Writeln('Количество отрицательных элементов не равно двум')
  else begin
    a:=SeqFill(b[0],0).Concat(a.Skip(b[0]).Take(b[1]-b[0]+1))
      .Concat(SeqFill(a.Length-b[1]-1,0)).ToArray;
    a.Println
    end
end.

Тестовое решение:
23 14 7 15 0 13 -6 41 18 13 8 42 27 -11 3 19 10
0 0 0 0 0 0 -6 41 18 13 8 42 27 -11 0 0 0

Файл с исходными данными имеет имя m17.txt. Тестовый файл находится во вложении. Разбивка на строки сделана по 5 значений, но может быть совершенно произвольной. Также нет привязки именно к 17 числам, главное - чтобы отрицательных чисел было ровно два, иначе будет выдано сообщение о их неверном количестве.
0,0(0 оценок)
Ответ:
147387492
12.12.2022 05:45
Под угрозой информационной безопасности принято понимать потенциально возможные действия, явления или процессы оказать нежелательное воздействие на систему или на хранящуюся в ней информацию.Такие угрозы, воздействуя на ресурсы, могут привести к искажению данных, копированию, несанкционированному распространению, ограничению или блокированию к ним доступа. В настоящее время известно достаточно  большое количество угроз, которые классифицируют по различным признакам.По природе возникновения различают естественные и искусственные угрозы. К первой группе относятся те, что вызваны воздействием на компьютерную систему объективных физических процессов или стихийных природных явлений. Вторая группа – те угрозы, которые обусловлены деятельностью человека.По степени преднамеренности проявления, угрозы разделяют на случайные ипреднамеренные.Также есть разделение в зависимости от их непосредственного источника, в качестве которого может выступать природная среда (например, стихийные бедствия), человек (разглашение конфиденциальных данных), программно-аппаратные средства: санкционированные (ошибка в работе операционной системы) и несанкционированные (заражение системы вирусами).Источник угроз может иметь разное положение. В зависимости от этого фактора также выделяют три группы:- Угрозы, источник которых находятся вне контролируемой группы компьютерной системы (пример – перехват данных, передаваемых по каналам связи)- Угрозы, источник которых – в пределах контролируемой зоны системы (это может быть хищение носителей информации)- Угрозы, находящиеся непосредственно в самой системе (например, некорректное использование ресурсов).Угрозы по-разному воздействовать на компьютерную  систему.  Это могут быть пассивные воздействия, реализация которых не влечет за собой изменение структуры данных (например, копирование). Активные угрозы — это такие, которые, наоборот, меняют структуру и содержание компьютерной системы (внедрение специальных программ).В соответствии с разделением угроз по  этапам доступа пользователей или программ к ресурсам системы существуют  такие опасности, которые проявляются на этапе доступа к компьютеру и обнаружимые после разрешения доступа (несанкционированное использование ресурсов).Классификация по месту расположения в системе подразумевает деление на три группы: угрозы доступа к информации, находящейся на  внешних запоминающих устройствах, в оперативной памяти и к той, что циркулирует в линиях связи.ОТВЕТ ВЗЯТ ИЗ ИНТЕРНЕТА!!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота