skipos
23.07.2021 20:04

Рассчитать параметры прямоугольного треугольника, в паскале.
1)
d = 180 - (90 + 30) = 60
2)
c = 2 \times a \\ c = 10
3)
b = \sqrt{c {}^{2} } - a {}^{2} \\ b = \sqrt{10 {}^{2} } - {5}^{2} = \sqrt{75 = 8}

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gspd000
02.05.2022 09:02

смотри ниже

Объяснение:

Выберите основные функции всех СУБД.

изменение (обновление, добавление и удаление) хранимых данных

обработка данных и вывод результатов

поиск и отбор данных по запросам пользователей

Определите количество полей в таблице базы данных «Магазин».

(поля это столбцы в таблице) их четыре штуки

Чему равно число записей в базе данных «Студенты»?

(запись это строка таблицы)  их три штуки

Какой тип данных нужно задать для поля "Группа" таблицы базы данных "Студенты"?

Текстовый

Какой тип будет у следующих полей: "Номер", "Дата", "Отметка о выполнении"?

Поле "Номер" будет числового типа, поле "Дата" - типа "Дата", а поле "Отметка о выполнении" - логического.

Укажите возможные ввода данных в таблицу базы данных.

Ввод через форму.

Ввод в таблицу в режиме "Ввод и редактирование данных"

Выберите основные объекты графического представления схемы данных.

таблицы и связи, определяемые внешними ключами

вроде так как-то, но не гарантирую.

0,0(0 оценок)
Ответ:
vladyulin
29.04.2021 23:44
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота