HorseOfDeath
17.11.2022 14:31

Ребзя, хэлпаните , горит дэдлайн:
напишите программу, которая считывает с клавиатуры одно дробное число и выводит обратное ему. если при этом введённое число меньше одной миллионной или равно 0, выводится миллион.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

Задание 5:

ответ:64=2^6 ---> 6 битов для кодировки одного ученика 72:6 = 12 учеников отобрано

Задание 6:

91 : 13 = 7 бит- на один файл

2^7 = 128 файлов- было

128 – 13 = 115 файлов- осталось

ответ: 115

Задание 7:По формуле Хартли N= 2^{i} вспоминаем степени двойки.

2⁵ = 32 => 1 буква несет 5 бит информации, ибо i = 5. Т.к в слове муравей 7 букв, то сообщение содержит 7 * 5 = 35 бит.

Задание 8:Решение:

i-?,

Число возможных информационных сообщений о положении крестика равно количеству клеток, т.е. 8*8=64, поэтому

N=2i , 64=2i, 2^6=2i, i=6.

ответ: 6 бит.

Задание 9:1) 2^5 = 32, поэтому на 1 букву 5 бит

2) 5 бит ∙ 5 букв = 25 бит, значит 25 вопросов

ответ: 25 вопросов

0,0(0 оценок)
Ответ:
agentponomarev6
01.12.2022 13:47
Const n =5;
var
  a:array[1..n] of integer;
  i,max:integer;
begin
  writeln('Введите 1 элемент массива');
  readln(a[1]); max:=a[1];
  for i:=2 to n do begin
    writeln('Введите ', i,' элемент массива');
    readln(a[i]);
    if a[i]>max then max := a[i];
  end;
  writeln('Максимальный элемент массива равен ',max);
end.

Тестовое решение:
Введите 1 элемент массива
21
Введите 2 элемент массива
56
Введите 3 элемент массива
12
Введите 4 элемент массива
24
Введите 5 элемент массива
15
Максимальный элемент массива равен 56
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота