11122223
19.12.2020 23:25

3номер. составить программу для вычисления элементов вектора x по формуле
формулу прикрепил

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Danyaizbanu
13.04.2020 06:13

Program ToDec;

Uses crt;
var s:string;
n,l,i:integer;

 

function Pow(x,y:integer):integer;
begin
     if y>0 then Pow:=Pow(x,y-1)*x
               else Pow:=1;
end;

function ToDec(A : string) : integer;
var L : Byte;
begin
      if A = '' then ToDec := 0
                else begin
                              L := length(A);
                               case A[1] of
                                     '0' : ToDec := ToDec(Copy(A, 2, L - 1));
                                     '1' : ToDec := Pow(2, L - 1) + ToDec(Copy(A, 2, L - 1));
                                end;
     end;
end;

begin
     clrscr;
     write('Введите двоичное число: ');
     readln(s);
      writeln('Это число в десятичной системе : ', ToDec(S));
 readkey;
end.

 

 

 

0,0(0 оценок)
Ответ:
DetaRUSION
13.04.2020 06:13

Program ToDec;

Uses crt;
var s:string;
n,l,i:integer;

 

function Pow(x,y:integer):integer;
begin
     if y>0 then Pow:=Pow(x,y-1)*x
               else Pow:=1;
end;

function ToDec(A : string) : integer;
var L : Byte;
begin
      if A = '' then ToDec := 0
                else begin
                              L := length(A);
                               case A[1] of
                                     '0' : ToDec := ToDec(Copy(A, 2, L - 1));
                                     '1' : ToDec := Pow(2, L - 1) + ToDec(Copy(A, 2, L - 1));
                                end;
     end;
end;

begin
     clrscr;
     write('Введите двоичное число: ');
     readln(s);
      writeln('Это число в десятичной системе : ', ToDec(S));
 readkey;
end.

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота