AntoniaMazhar
03.04.2022 09:11

Составить программу преобразования натуральных чисел, записанных в римской системе счисления, в десятичную систему счисления. 2. дана строка, содержашая текст на языке. выяснить, сколько раз встречается в ней самое короткое слово. 3. дана строка, содержащая текст, включающий и слова. получить новую строку, заменив в исходной все заглавные буквы строчными и наоборот.
, . ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hovrashok
26.04.2021 19:45

1. В)

2. Б)

3. Г)

4. Б)

5. А), В)

6. Г)

7. А) животные, Б) одежда, В) слова, Г) деревья, Д)кисломолочные продукты, Е) цифры.

8. Ещё подумаю

9. 1) макароны, 2) песня, 3) песок, 4)шарф.

10. Например: 1) 5; 2) 5×5=25; 3)25×2=50; 4) 50+4=54; 5) 54-8=46; 6) 6; 7) 6×7=42; 8) 42:2=21 и 1) 3; 2) 3×5=15; 3) 15×2=30; 4)30+4=34; 5)34-8=26; 6) 6; 7)6×7=42; 8)42:2=21

Вывод: если взять любое число кроме нуля и выполнить с ним эту последовательность действий, то получается одно и тоже число-21.

11. 1) Раньше всех пришла лиса.

2) 1 - Лиса, 2 - медведь, 3 - заяц, 4 - волк, 5 - сорока.

12. Вариант - 1

1. В ведро вместимостью 8 л налить 5 л.

2. В банку вместимостью 5 л налить 2 л.

Вариант - 2

Ведро вместимостью 8 л налить 7 л.

0,0(0 оценок)
Ответ:
Nikuiii
08.04.2022 02:32

program HomeWork;

var k,n,j:integer;

function IsPrime(a:integer):boolean;

var i:integer;

begin

   IsPrime:=True;

   for i:=2 to a-1 do

   begin

       if a mod i = 0 then

       begin

           IsPrime:=False;

           break

       end

   end

end;

function IsSumEven(a:integer):boolean;

var i,s:integer;

begin

   IsSumEven:=False;

   s:=0;

   while a > 0 do

   begin

      i:=a mod 10;

      a:=a div 10;

      s:=s+i

   end;

   if s mod 2 = 0 then IsSumEven:=True

end;

begin

   write('Введите два натуральных числа, разделённые пробелом, K и N ( 2 ≤ K ≤ N ≤ 100000 ): '); readln(k,n);

   for j:=k to n do

   begin

       if IsPrime(j) = True then if IsSumEven(j) = True then write(j, ' ')

   end

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота