89232752183
13.03.2022 20:03

Решить в питоне (python) 11 !
надо написать программу, которая принимает текст и выводит два слова слова: наиболее часто встречающееся слова и самое длинное слово.

буду .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ulagrac8
17.08.2020 11:53

n = input()

n=n.replace("."," ")

n=n.replace(","," ")

n=n.replace("!"," ")

n=n.replace("?"," ")

n=n.replace("-"," ")

n=n.replace("("," ")

n=n.replace(")"," ")

n = n.split()

maxlength = ""

maxcount  = ""

for a in range(len(n)):

   if len(n[a])>len(maxlength):

       maxlength = n[a]

   if n.count(n[a])>len(maxcount):

       maxcount = n[a]

 

print("maxcount: "+maxcount)

print("maxlength: "+maxlength)

Объяснение:

есть нюанс:а что если 2 или больше слова которые может быть одинаково длиной какую должен выводит?

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота