olesazato
09.08.2021 11:08

Написать программу на c++, которая обрабатывает введенную строку и выставляет все буквы в алфавитном порядке, например ввод: input example вывод: aeilmnptux

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lapkinalidala
10.10.2020 10:09

#include <iostream>

#include <string>

#include <windows.h>   // для русских букв, можно удалить

using namespace std;

int main()

{

 string s, ss = "";

 int i, l, imin;

 setlocale(LC_ALL, "Russian");

 SetConsoleCP(1251);         // для русских букв, можно удалить

 SetConsoleOutputCP(1251);   // для русских букв, можно удалить

 cout << "Введите строку: ";

 getline (cin, s);

 while (s != "") {

   l = s.length();

   imin = 0;

   for (i = 0; i < l; i++) {

     if (s[i] < s[imin]) {

       imin = i;

     }

   }

   ss = ss + s[imin];

   s.erase(imin, 1);

 }

 cout << "\nРезультат: " << ss << "\n";

}

Объяснение:

если русские буквы не нужны можно удалить операторы с соответствующими комментариями

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота