RAYDEN02
24.03.2022 03:58

Написать программу с постусловием)с#
1. для десяти выстрелов, координаты которых с клавиатуры, вывести тестовые сообщения и попадании в мишень.
2. составить программу, которая определяет сумму s и количество k целых чисел лежащих на заданном отрезке [a; b]. границы отрезка целые числа.
3. реализовать консольное меню с циклы do-while. выбор пунктов осуществляется вводом номера через клавиатуру. выбрав первый пункт меню, выводится ваше имя и возврат в меню, второй пункт – фамилия и возврат в меню, третий пункт – группа и возврат в меню, четвертый – выход из программы.
4. осуществить вывод в цикле построчно на экран чисел от n-5 до n+5, где n номер варианта. в теле цикла сначала реализовать проверку значения на равенство варианту (использовать условный оператор if) и в случае истинного результата выполнить оператор continue, а затем осуществить вывод на экран текущего значения.
5. реализовать тот же цикл что и в предыдущем , но вместо оператора continue использовать оператор break. проанализировать отличия в данных операторах.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Misha01923
03.03.2021 20:02
Var a: array of integer; // Объявление массива целых чисел
  i, n: integer; // объявление целочисленных переменных
begin
  // Запросим с клавиатуры размер массива
  // и запишем его в переменную n
  write('введите n:'); 
  readln(n);
  
  // Теперь выделим память под n элементов массива
  SetLength(a, n);
  
  // теперь запросим с клавиатуры n чисел для массива
  for i := 0 to n-1 do begin
    write('a[', i, ']=');
    readln(a[i]);
  end;
  
  // теперь в цикле уменьшим каждый элемент на единицу
  for i := 0 to n-1 do 
    a[i] := a[i] - 1;
  
  // распечатаем массив
  for i := 0 to n-1 do 
    write(a[i], ' ');
end.
0,0(0 оценок)
Ответ:
КулБои
16.12.2020 20:44
Пять верст до небес и все лесом. 
Эка верста выросла (как Коломенская верста) . 
За семь верст киселя хлебать. 
Ты от дела на недельку, а оно от тебя на саженьку. 
Видеть на сажень сквозь землю. 
Загадка разгадка да семь верст правды. 
Каждый купец на свой аршин мерит. 
Прямой, будто аршин проглотил. 
Семи пядей во лбу. 
Сам с ноготок, а борода с локоток. 
От горшка два вершка, а уже указчик. 
Полено к полену - сажень. 
Москва верстой далека, а сердцу рядом. 
Любовь верстами не меряется. 
Сто верст молодцу не крюк. 
От слова до дела - целая верста. 
Верстой ближе - пятаком дешевле. 
Жили с локоть, а осталось с ноготь. 
В чужих руках ноготок с локоток. 
Дай с ноготок, запросит с локоток. 
Семь аршин говядины да три фунта лент (о бессмыслице)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота