умник202323
16.10.2022 09:22

Чему равно значение переменной s в результате выполнение программы

Program mas;

Var s,m: integer;

Arry B[1..6] of integer;

Begin

s:=0;

For m:=1 to 6 do

begin

B[m]:=m*m;

If B[m]>=10 then

s:=s+1;
end;

Writeln ('s=',s);

end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Lis25pfi174
01.11.2022 17:39
//PascalABC.NET 3.2 сборка 1318

Var
  arnx,armx,arny,army,delMmax:array[1..1000] of real;
  N,M,res,i,j:integer;
  min:real;
begin
min:=maxreal;
{не уверен существует ли эта константа в fpc, если что, она равна максимальному значению типа real}
readln(N);
for i:=1 to N do
    readln(arnx[i],arny[i]);
readln(M);
for i:=1 to M do
  begin
    readln(armx[i],army[i]);
    delMmax[i]:=-1;
    for j:=1 to N do
      if delMmax[i]<sqrt(sqr(armx[i]-arnx[j])+sqr(army[i]-arny[j]))
 then
 delMmax[i]:=sqrt(sqr(armx[i]-arnx[j])+sqr(army[i]-arny[j]));
    if delMmax[i]<min
 then
      begin
        min:=delMmax[i];
        res:=i;
      end;
 end;
writeln(res);
end.

Пример ввода:
3
2 1
1 2
1 1
3
1 5
3 3
4 2
Пример вывода:
2
0,0(0 оценок)
Ответ:
KolianN
14.02.2022 01:16
From random import shuffle
 
points = 0
points_per_turn = 100
lives = 3
rooms = [("В комнате дракон :(", -1), ("В комнате живая вода :)", 1), ("Комната пуста :|", 0)]
n = len(rooms)
 
while lives > 0:
  print("Жизней: ", lives, ", очков: ", points, sep = "")
  shuffle(rooms)
  print("Выбирайте любую из дверей, введите число от 1 до", n, end=" ")
  choice = int(input()) - 1
  points += points_per_turn
  print(rooms[choice][0])
  lives += rooms[choice][1]
 
print("Коварный дракон лишил вас последней жизни, но тем не менее у вас осталось", points, "очков.")
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота