rewington1
15.07.2020 12:14

Паскаль,составить программу! 1.дано слово,определить есть ли в нем буква а! паскаль! (ответить на вопрос да или нет)2.дано предложение,определить длину последнего слова.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sasha280405
12.01.2022 08:12
1 задача:

const n=10;
var 
  min,i: integer;
  a: array[1..n] of integer;
begin
  randomize;
  min:=11;
  for i:=1 to n do begin
    a[i]:=random(1,10);
    write (a[i],' '); // для наглядности. можно удалить
    if  (i mod 2 =1) and (a[i]<min) 
      then min:=a[i];    
  end;
  writeln;
  writeln ('min = ',min)
end.

Пример:
5 4 7 8 6 2 10 4 9 9 
min = 5


2 задача:

const n=10;
var 
  max,count,i: integer;
  a: array[1..n] of integer;
begin
  randomize;
  max:=0;
  count:=0;
  for i:=1 to n do begin
    a[i]:=random(1,10);
    write (a[i],' '); // для наглядности. можно удалить
    if a[i]>max
      then max:=a[i];     
  end;
  for i:=1 to n do 
    if max=a[i] then count:=count+1;
  writeln;
  writeln ('max = ',max);
  writeln ('count = ',count);
end.

Пример:
8 5 3 2 2 10 10 9 3 10 
max = 10
count = 3
0,0(0 оценок)
Ответ:
глаголица545
25.02.2021 16:21

Пример на языке с++, дошел только для этого

#include<iostream>

using namespace std;

int min(int a, int b, int c, int d)

{

 int min1 = 0;

 int min2 = 0;

 if (a < b)

 {

  min1 = a;

 }

 else

 {

  min1 = b;

 }

 if (c < d)

 {

  min2 = c;

 }

 else

 {

  min2 = d;

 }

 if (min1 < min2)

 {

  cout << "Наименьшее из чисел: " << min1 << endl;

 }

 else

 {

  cout << "Наименьшее из чисел: " << min2 << endl;

 }

 return 0;

 

 

 

 

}

int main()

{

setlocale(LC_ALL,"RUSSIAN");

min(10,20,30,40);

 

return 0;

 

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота