Meshnyakova52
16.01.2022 10:47

Написать программу, которая вычисляет сумму первых n членов ряда 1, 3, 5, 7, … . количество суммируемых членов ряда задается во время работы программы.

нужно написать программу на паскале, с цикла "for 1 to 5 do" и

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DEM0KRAT
11.09.2020 11:13

1, 3, 5, 7, ... - арифметическая прогрессия, в которой первый член a1=1 и разность d=7-5=5-3=3-1=2.

запишем формулу n члена прогрессии:

an=a1+d(n-1)=1+2n-2=2n-1, где n - номер члена последовательности.

Составляем программу:

var n,s,i: integer;

begin

readln(n);

s:=1;

for i:=2 to n do s:=s+2*i-1;

write('сумма: ',s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота