siyashka1
06.06.2020 18:11

Написать программу на языке !
1)дан текст. определите количество цифр в нем.
2)вывести на экран числа в виде следующей таблицы:
41 42 50
51 52 60
61 62 70
71 72 80
3)дан текст, в котором имеются цифры. найдите их сумму.
тема: вложенные циклы​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KirillK2014
17.03.2022 06:09
Если создаваемый документ содержит много страниц и включает разделы, подразделы и т.п., то для удобства пользования им целесообразно создавать оглавление (как это делается в книгах). Создание оглавления возможно только в документе, который имеет иерархическую структуру, включающую как минимум два уровня иерархии и заголовки разделов и подразделов, созданные с применением стилей с наименованием Заголовок, или с стилей пользователя, созданных на основе стилей Заголовок. Заметим, что Word Позволяет создавать документы с иерархией до девяти уровней.

Как создать оглавление с использованием стилей заголовков?

Наиболее простым создания оглавления является использование встроенных форматов уровней структуры или стилей заголовков. Если встроенные форматы уровней структуры или стили заголовков уже используются, выполните следующие действия:

1. Установите мерцающий курсор в место вставки оглавления.

2. На ленте Ссылки в группе Оглавление раскройте список Оглавление.

3. Чтобы воспользоваться одним из готовых решений, кликните нужный вариант оглавления в списке.

Если вы хотите сделать настраиваемое оглавление, то:

1. В списке Оглавление выберите пункт Настраиваемое оглавление – откроется окно диалога Оглавление.

2. Во вкладке Оглавление диалогового окна Параметры оглавления укажите нужные параметры.

Если уровни структуры или встроенные заголовки не используются, то следует определить структуру документа.

Это имелось ввиду?)
0,0(0 оценок)
Ответ:
atchaschinovр
05.01.2022 05:18

k = float(input())

s = float(input())

p= float(input())

i = 0

while k < s:

    i += 1

    k += (k / 100)*p

print(f'Через {i} месяцев! Вы получите сумму {k}')

Объяснение:

Вводим нужные числа.

И так, i = это у нас месяцы, которая по умолчанию равна 0.

while у нас заместо времени, каждая итерация while прибавляет к месяцам 1.

И так - каждый месяц мы увеличиваем наш капитал на p.

k += (k/100)*p - считаем проценты.

Насчёт += - это тоже самое, что написать k = k + (k/100) * p.

Условие цикла, цикл будет работать, пока наш капитал меньше нужной суммы.

Как только капитал становиться больше нужной суммы - while прекращает свою работу. И мы получаем через сколько месяцев наберём нужный капитал.

*f - format

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота